Click or drag to resize

GH_String Class

Represents a literal string. GH_String re-implements the framework System.String type.
Inheritance Hierarchy
SystemObject
  Grasshopper.Kernel.TypesGH_GooString
    Grasshopper.Kernel.TypesGH_String

Namespace:  Grasshopper.Kernel.Types
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public class GH_String : GH_Goo<string>

The GH_String type exposes the following members.

Constructors
  NameDescription
Public methodGH_String
Blank constructor
Public methodGH_String(GH_String)
Initializes a new instance of the GH_String class
Public methodGH_String(String)
Initializes a new instance of the GH_String class
Top
Properties
  NameDescription
Public propertyIsValid
Gets the validity of this instance. String are valid if they are not null.
(Overrides GH_GooTIsValid.)
Public propertyIsValidWhyNot
Gets a string describing the state of "invalidness". If the instance is valid, then this property should return Nothing or String.Empty.
(Overrides GH_GooTIsValidWhyNot.)
Public propertyTypeDescription (Overrides GH_GooTTypeDescription.)
Public propertyTypeName (Overrides GH_GooTTypeName.)
Top
Methods
  NameDescription
Public methodCastFrom (Overrides GH_GooTCastFrom(Object).)
Public methodCastToT(T) (Overrides GH_GooTCastToQ(Q).)
Public methodDuplicate (Overrides GH_GooTDuplicate.)
Public methodDuplicateString
Public methodEmitProxy (Overrides GH_GooTEmitProxy.)
Public methodRead (Overrides GH_GooTRead(GH_IReader).)
Public methodToString (Overrides GH_GooTToString.)
Public methodWrite (Overrides GH_GooTWrite(GH_IWriter).)
Top
Fields
See Also