Click or drag to resize

GH_StructurePath Class

Inheritance Hierarchy
SystemObject
  Grasshopper.Kernel.TypesGH_GooGH_Path
    Grasshopper.Kernel.TypesGH_StructurePath

Namespace:  Grasshopper.Kernel.Types
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public class GH_StructurePath : GH_Goo<GH_Path>

The GH_StructurePath type exposes the following members.

Constructors
  NameDescription
Public methodGH_StructurePath
Blank constructor
Public methodGH_StructurePath(GH_Path)
Initializes a new instance of the GH_StructurePath class
Public methodGH_StructurePath(GH_StructurePath)
Initializes a new instance of the GH_StructurePath class
Top
Properties
  NameDescription
Public propertyIsValid
Gets the validity of this instance. Integers are always valid
(Overrides GH_GooTIsValid.)
Public propertyTypeDescription (Overrides GH_GooTTypeDescription.)
Public propertyTypeName (Overrides GH_GooTTypeName.)
Public propertyValue (Overrides GH_GooTValue.)
Top
Methods
  NameDescription
Public methodCastFrom (Overrides GH_GooTCastFrom(Object).)
Public methodCastToT(T) (Overrides GH_GooTCastToQ(Q).)
Public methodDuplicate (Overrides GH_GooTDuplicate.)
Public methodDuplicatePath
Public methodEmitProxy (Overrides GH_GooTEmitProxy.)
Public methodRead (Overrides GH_GooTRead(GH_IReader).)
Public methodScriptVariable (Overrides GH_GooTScriptVariable.)
Public methodToString (Overrides GH_GooTToString.)
Public methodWrite (Overrides GH_GooTWrite(GH_IWriter).)
Top
Fields
See Also