Click or drag to resize

GH_Surface Class

Represents a 3D (trimmed) surface. GH_Surface wraps the functionality of the OpenNURBS OnBrepFace class.
Inheritance Hierarchy
SystemObject
  Grasshopper.Kernel.TypesGH_GooBrep
    Grasshopper.Kernel.TypesGH_GeometricGooBrep
      Grasshopper.Kernel.TypesGH_Surface

Namespace:  Grasshopper.Kernel.Types
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public class GH_Surface : GH_GeometricGoo<Brep>, 
	IGH_BakeAwareData, IGH_PreviewData, IGH_PreviewMeshData, IGH_RenderAwareData

The GH_Surface type exposes the following members.

Constructors
  NameDescription
Public methodGH_Surface
Initializes a new instance of the GH_Surface class
Public methodGH_Surface(Brep)
Initializes a new instance of the GH_Surface class
Public methodGH_Surface(GH_Surface)
Initializes a new instance of the GH_Surface class
Public methodGH_Surface(Guid)
Initializes a new instance of the GH_Surface class
Public methodGH_Surface(Surface)
Initializes a new instance of the GH_Surface class
Top
Properties
  NameDescription
Public propertyBoundingbox (Overrides GH_GeometricGooTBoundingbox.)
Public propertyClippingBox
Public propertyFace
Public propertyIsGeometryLoaded (Overrides GH_GeometricGooTIsGeometryLoaded.)
Public propertyIsValid (Overrides GH_GeometricGooTIsValid.)
Public propertyIsValidWhyNot
Gets a string describing the state of "invalidness". If the instance is valid, then this property should return Nothing or String.Empty.
(Overrides GH_GooTIsValidWhyNot.)
Public propertyReferenceID (Overrides GH_GeometricGooTReferenceID.)
Public propertyTypeDescription (Overrides GH_GooTTypeDescription.)
Public propertyTypeName (Overrides GH_GooTTypeName.)
Public propertyValue (Overrides GH_GeometricGooTValue.)
Top
Methods
  NameDescription
Public methodAppendRenderGeometry
Public methodBakeGeometry
Public methodCastFrom (Overrides GH_GeometricGooTCastFrom(Object).)
Public methodCastToT(T) (Overrides GH_GeometricGooTCastToQ(Q).)
Public methodClearCaches (Overrides GH_GeometricGooTClearCaches.)
Public methodDestroyPreviewMeshes
Public methodDrawViewportMeshes
Public methodDrawViewportWires
Public methodDuplicate (Overrides GH_GeometricGooTDuplicate.)
Public methodDuplicateGeometry (Overrides GH_GeometricGooTDuplicateGeometry.)
Public methodDuplicateSurface
Public methodEmitProxy (Overrides GH_GeometricGooTEmitProxy.)
Public methodGetBoundingBox (Overrides GH_GeometricGooTGetBoundingBox(Transform).)
Public methodGetPreviewMeshes
Public methodIsPointOnDomain
Public methodIsPointOnFace
Public methodLoadGeometry(RhinoDoc) (Overrides GH_GeometricGooTLoadGeometry(RhinoDoc).)
Public methodMorph (Overrides GH_GeometricGooTMorph(SpaceMorph).)
Public methodRead (Overrides GH_GooTRead(GH_IReader).)
Public methodScriptVariable (Overrides GH_GooTScriptVariable.)
Public methodToString (Overrides GH_GooTToString.)
Public methodTransform (Overrides GH_GeometricGooTTransform(Transform).)
Public methodUntrim
Public methodWrite (Overrides GH_GooTWrite(GH_IWriter).)
Top
Fields
See Also