Click or drag to resize

GH_Transform Class

Represents a collection of transformations.
Inheritance Hierarchy
SystemObject
  Grasshopper.Kernel.TypesGH_GooTransform
    Grasshopper.Kernel.TypesGH_Transform

Namespace:  Grasshopper.Kernel.Types
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public class GH_Transform : GH_Goo<Transform>

The GH_Transform type exposes the following members.

Constructors
  NameDescription
Public methodGH_Transform
Initializes a new instance of the GH_Transform class
Public methodGH_Transform(GH_Transform)
Initializes a new instance of the GH_Transform class
Public methodGH_Transform(ITransform)
Initializes a new instance of the GH_Transform class
Public methodGH_Transform(Transform)
Initializes a new instance of the GH_Transform class
Top
Properties
  NameDescription
Public propertyCompoundTransforms
Gets the internal set of transforms. If you modify the compound transformations, you must call ClearCaches().
Public propertyIsValid (Overrides GH_GooTIsValid.)
Public propertyIsValidWhyNot
Gets a string describing the state of "invalidness". If the instance is valid, then this property should return Nothing or String.Empty.
(Overrides GH_GooTIsValidWhyNot.)
Public propertyTypeDescription (Overrides GH_GooTTypeDescription.)
Public propertyTypeName (Overrides GH_GooTTypeName.)
Public propertyValue (Overrides GH_GooTValue.)
Top
Methods
  NameDescription
Public methodCastFrom (Overrides GH_GooTCastFrom(Object).)
Public methodCastToQ(Q) (Overrides GH_GooTCastToQ(Q).)
Public methodClearCaches
Erase the compound transformation caches.
Public methodDuplicate (Overrides GH_GooTDuplicate.)
Public methodEmitProxy
Returns a proxy that represents this transform. Do not call this function unless you're
(Overrides GH_GooTEmitProxy.)
Public methodGetInverse
Public methodRead (Overrides GH_GooTRead(GH_IReader).)
Public methodScriptVariable (Overrides GH_GooTScriptVariable.)
Public methodToString (Overrides GH_GooTToString.)
Public methodWrite (Overrides GH_GooTWrite(GH_IWriter).)
Top
Fields
See Also