Click or drag to resize

Rotation Class

Implements a rotation transformation.
Inheritance Hierarchy
SystemObject
  Grasshopper.Kernel.Types.TransformsRotation

Namespace:  Grasshopper.Kernel.Types.Transforms
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public class Rotation : ITransform

The Rotation type exposes the following members.

Constructors
  NameDescription
Public methodRotation
Initializes a new instance of the Rotation class
Public methodRotation(Point3d, Vector3d, Vector3d)
Initializes a new instance of the Rotation class
Public methodRotation(Point3d, Vector3d, Double)
Initializes a new instance of the Rotation class
Top
Properties
Methods
See Also