Click or drag to resize

Scale Class

Implements a scaling transformation.
Inheritance Hierarchy
SystemObject
  Grasshopper.Kernel.Types.TransformsScale

Namespace:  Grasshopper.Kernel.Types.Transforms
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public class Scale : ITransform

The Scale type exposes the following members.

Constructors
  NameDescription
Public methodScale
Initializes a new instance of the Scale class
Public methodScale(Plane, Double)
Initializes a new instance of the Scale class
Public methodScale(Point3d, Double)
Initializes a new instance of the Scale class
Public methodScale(Plane, Double, Double, Double)
Initializes a new instance of the Scale class
Top
Properties
Methods
See Also