Click or drag to resize

GH_GenericObjectAction Class

Records a single object change. Object changes are undone/redone by (de)serializing the objects. Object changes also keep track of all wires feeding into and coming out of the object.
Inheritance Hierarchy

Namespace:  Grasshopper.Kernel.Undo.Actions
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public class GH_GenericObjectAction : GH_ArchivedUndoAction

The GH_GenericObjectAction type exposes the following members.

Constructors
  NameDescription
Public methodGH_GenericObjectAction
Initializes a new instance of the GH_GenericObjectAction class
Top
Properties
  NameDescription
Public propertyExpiresSolution (Overrides GH_UndoActionExpiresSolution.)
Top
Methods
  NameDescription
Protected methodInternal_Redo (Overrides GH_UndoActionInternal_Redo(GH_Document).)
Protected methodInternal_Undo (Overrides GH_UndoActionInternal_Undo(GH_Document).)
Top
Fields
  NameDescription
Top
See Also