Click or drag to resize

GH_PersistentDataActionT Class

Records the changes in the persistent data of a parameter.
Inheritance Hierarchy
SystemObject
  Grasshopper.Kernel.UndoGH_UndoAction
    Grasshopper.Kernel.UndoGH_ObjectUndoAction
      Grasshopper.Kernel.Undo.ActionsGH_PersistentDataActionT

Namespace:  Grasshopper.Kernel.Undo.Actions
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public class GH_PersistentDataAction<T> : GH_ObjectUndoAction
where T : class, IGH_Goo

Type Parameters

T

The GH_PersistentDataActionT type exposes the following members.

Constructors
  NameDescription
Public methodGH_PersistentDataActionT
Initializes a new instance of the GH_PersistentDataActionT class
Top
Properties
  NameDescription
Public propertyExpiresSolution (Overrides GH_UndoActionExpiresSolution.)
Top
Methods
See Also