Click or drag to resize

GH_ArchivedUndoAction Class

Base class implementation for undo actions that require (de)serialization of data.
Inheritance Hierarchy

Namespace:  Grasshopper.Kernel.Undo
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public abstract class GH_ArchivedUndoAction : GH_UndoAction

The GH_ArchivedUndoAction type exposes the following members.

Constructors
  NameDescription
Protected methodGH_ArchivedUndoAction
Initializes a new instance of the GH_ArchivedUndoAction class
Top
Properties
  NameDescription
Top
Methods
  NameDescription
Protected methodDeserialize
Deserializes the obj from the local archive.
Public methodRead (Overrides GH_UndoActionRead(GH_IReader).)
Protected methodSerialize
Serializes the obj into the local archive.
Protected methodSerializeToByteArray
Serializes the obj into the local archive.
Public methodWrite (Overrides GH_UndoActionWrite(GH_IWriter).)
Top
Fields
  NameDescription
Protected fieldm_data
Internal data storage for serialized archives.
Top
See Also