Click or drag to resize

IGH_UndoAction Interface

Base interface for all undo/redo actions

Namespace:  Grasshopper.Kernel.Undo
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public interface IGH_UndoAction : GH_ISerializable

The IGH_UndoAction type exposes the following members.

Properties
  NameDescription
Public propertyExpiresDisplay
Gets the display expiration flag for this event. If True, the Rhino viewports will be redrawn once the entire undo record has been completed. If ExpiresSolution is set to true, ExpriresDisplay is implied.
Public propertyExpiresSolution
Gets the solution expiration flag for this event. If True, the solution needs to be recalculated once the entire undo record has been completed.
Public propertyState
Gets the current state of the undo action.
Top
Methods
  NameDescription
Public methodRedo
Redo the action stored in this record.
Public methodUndo
Undo the action stored in this record.
Top
See Also