Click or drag to resize

GH_PluginUtil Class

Grasshopper plugin utility class. This class exports some static (Shared in VB) methods to do with plugin loading and unloading.
Inheritance Hierarchy
SystemObject
  Grasshopper.PluginGH_PluginUtil

Namespace:  Grasshopper.Plugin
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public sealed class GH_PluginUtil

The GH_PluginUtil type exposes the following members.

Methods
  NameDescription
Public methodStatic memberBringRhinoToTop
Bring the Rhino window to the top of the stack.
Public methodStatic memberBringWindowToTop
Public methodStatic memberFocusOnRhino
Set the focus to the Rhino command line.
Public methodStatic memberSendKeyCodeToRhino(Char)
Send a key-code to the Rhino command line.
Public methodStatic memberSendKeyCodeToRhino(Int32)
Send a key-code to the Rhino command line.
Public methodStatic memberSendKeyCodeToRhino(String)
Send a string of characters to the Rhino command line.
Public methodStatic memberSendMessage
Public methodStatic memberSetFocus
Top
See Also