Click or drag to resize

GH_RhinoScriptInterface Class

Plugin Interface object that is exposed via the RhinoScript layer.
Inheritance Hierarchy
SystemObject
  Grasshopper.PluginGH_RhinoScriptInterface

Namespace:  Grasshopper.Plugin
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public class GH_RhinoScriptInterface

The GH_RhinoScriptInterface type exposes the following members.

Constructors
  NameDescription
Public methodGH_RhinoScriptInterface
Initializes a new instance of the GH_RhinoScriptInterface class
Top
Methods
  NameDescription
Public methodAssignDataToParameter
Find a parameter and assign some persistent data.
Public methodBakeDataInObject
Find an object and bake all geometry inside of it.
Public methodCode exampleCloseAllDocuments
Close all Grasshopper documents.
Public methodCode exampleCloseDocument
Close the currently active Grasshopper document. If there is not active document, nothing will happen.
Public methodCode exampleDisableBanner
Disables the display of the Grasshopper banner during Component loading. The banner is typically only shown once during a Grasshopper session, namely when the Editor is first loaded.
Public methodCode exampleDisableSolver
Disables the Grasshopper Solver. If the Solver is disabled, expired components and parameter will not be recomputed, though any existing solution will remain intact.
Public methodCode exampleEnableBanner
Enables the display of the Grasshopper banner during Component loading. The banner is typically only shown once during a Grasshopper session, namely when the Editor is first loaded.
Public methodCode exampleEnableSolver
Enables the Grasshopper Solver. If the Solver is enabled, expired components and parameter will be recomputed.
Public methodCode exampleHideEditor
Hide the main Grasshopper Editor. If the editor hasn't been loaded or if the Editor is already hidden, nothing will happen.
Public methodCode exampleIsEditorLoaded
Returns the loaded state of the Grasshopper Main window.
Public methodCode exampleIsEditorVisible
Returns the visible state of the Grasshopper Main window.
Public methodCode exampleIsSolverEnabled
Returns the state of the Grasshopper Solver.
Public methodCode exampleLoadEditor
Load the main Grasshopper Editor. If the editor has already been loaded nothing will happen.
Public methodCode exampleOpenDocument
Open a Grasshopper document. The editor will be loaded if necessary, but it will not be automatically shown.
Public methodRunAsCommand
Public methodRunHeadless
Public methodRunSolver
Runs the solver once, even if the global solver lock is on.
Public methodCode exampleSaveDocument
Save the currently active Grasshopper document. If the active document has never been saved, a Save... dialog will be shown. If there is no active document, nothing will happen.
Public methodCode exampleSaveDocumentAs
Save the currently active Grasshopper document in a specific location. If there is no active document, nothing will happen.
Public methodSetSliderRangeAndValue
Find a slider and assign a new value.
Public methodSetSliderValue
Find a slider and assign a new value.
Public methodCode exampleShowEditor
Show the main Grasshopper Editor. The editor will be loaded first if needed. If the Editor is already on screen, nothing will happen.
Top
See Also