Click or drag to resize

Utility Class

Class with useful static methods.
Inheritance Hierarchy
SystemObject
  GrasshopperUtility

Namespace:  Grasshopper
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public sealed class Utility

The Utility type exposes the following members.

Methods
  NameDescription
Public methodStatic memberDocumentAngleTolerance
Returns the Angle Tolerance in degrees for the model document
Public methodStatic memberDocumentTolerance
Returns the Absolute Tolerance of the model document
Public methodStatic memberDocumentUnits
Returns the unit system for the model document
Public methodStatic memberFixNewlines(String)
Make sure all newlines in a string adhere to the current platform standard.
Public methodStatic memberFixNewlines(String, String)
Make sure all newlines in a string have a specific pattern.
Public methodStatic memberInvokeDownloader
Start an asynchronous download operation. The download runs in a separate appdomain. After triggering that process this method returns immediately.
Public methodStatic memberInvokeGetter
Call a getter property via its name.
Public methodStatic memberInvokeGetterSafe
Call a getter property via its name. No exceptions are thrown.
Public methodStatic memberInvokeMethod(Object, String)
Call a method via its name.
Public methodStatic memberInvokeMethod(Object, String, Object)
Call a method via its name.
Public methodStatic memberInvokeMethodSafe(Object, String)
Call a method via its name. No exceptions are thrown.
Public methodStatic memberInvokeMethodSafe(Object, String, Object)
Call a method via its name. No exceptions are thrown.
Public methodStatic memberInvokeSetter
Call a setter property via its name.
Public methodStatic memberInvokeSetterSafe
Call a setter property via its name. No exceptions are thrown.
Public methodStatic memberLikeOperator
Exposes the VB.NET Like operator as a static method.
Public methodStatic memberSetDefaultTolerances
Utility function to set absolute and angle tolerance fields.
Public methodStatic memberSetDefaultUnits
Utility function to set model unit fields
Public methodStatic memberTernaryIfT Obsolete.
Type safe implementation of the IIf conditional statement.
Top
See Also