BlockInstanceId

Returns the block definition identifier of a block instance object.

Syntax

Rhino.BlockInstanceId (strObject)

Parameters

strObject

Required.  String.  The identifier of an existing block instance object.

Returns

String

The block definition identifier if successful.

Null

If not successful, or on error.

Example

Dim strObject

strObject = Rhino.GetObject("Select block")

If Rhino.IsBlockInstance(strObject) Then

Call Rhino.Print(Rhino.BlockInstanceId(strObject))

End If

Also See

BlockInstanceCount

BlockInstanceName

BlockInstances

BlockInstanceXform

IsBlockInstance