IsBlock

Verifies the existence of a block definition in the document.

Syntax

Rhino.IsBlock (strBlock)

Parameters

strBlock

Required.  String.  The name or identifier of an existing block definition.

Returns

Boolean

True or false indicating success or failure.

Null

On error.

Example

Dim strBlock

strBlock = Rhino.GetString("Block name")

If Rhino.IsBlock(strBlock) Then

Rhino.Print "The block definition exists."

Else

Rhino.Print "The block definition does not exist."

End If

Also See

IsBlockEmbedded

IsBlockInstance

IsBlockInUse

IsBlockReference