AddCircleTanTan

Adds a circle curve that is tangent to 2 curves to the document.

Syntax

Rhino.AddCircleTanTan (strCurve1, strCurve2 [, dblSeed1 [, dblSeed2]])

Parameters

strCurve1

Required.  String. The identifier of the first curve object.

strCurve2

Required.  Array.  The identifier of the second curve object.

dblSeed1

Optional.  Number.  A 'seed' parameter on the first curve object. If omitted, the parameter at the start of the curve is used.

dblSeed2

Optional.  Number.  A 'seed' parameter on the second curve object. If omitted, the parameter at the start of the curve is used.

Returns

String

The identifier of the new object if successful.

Null

If not successful, or on error.

Example

Dim arrCurve1, arrCurve2

arrCurve1 = Rhino.GetCurveObject("First curve")

arrCurve2 = Rhino.GetCurveObject("Second curve")

Call Rhino.AddCircleTanTan(arrCurve1(0), arrCurve2(0), arrCurve1(4), arrCurve2(4))

Also See

AddCircle

AddCircle3Pt

AddCirclePtTanPt

AddCircleTanTanTan

IsCircle