IsArc

Verifies an object is an arc curve object or is a NURBS curve object that looks like an arc.

Syntax

Rhino.IsArc (strObject [, intIndex [, dblTolerance]])

Parameters

strObject

Required.  String.  The object's identifier.

intIndex

Optional.  Number. If strObject identifies a polycurve object, then intIndex identifies the curve segment of the polycurve to query.

dblTolerance

Optional.  Number.  If the curve is not an arc curve object, then the tolerance used to determine whether or not the NURBS form of the curve has the properties of an arc. If omitted, Rhino's internal zero tolerance is used.

Returns

Boolean

True if successful, otherwise False.

Null

On error.

Example

Dim strObject

strObject = Rhino.GetObject("Select an arc")

If Rhino.IsArc(strObject) Then

Rhino.Print "The object is an arc."

Else

Rhino.Print "The object is not an arc."

End If

Also See

AddArc3Pt

ArcAngle

ArcCenterPoint

ArcMidPoint

ArcRadius