SoftEditCurve

Moves the curve area surrounding a selected point smoothly relative to the distance from selected point. For more details, see the Rhino help file for the SoftEditCrv command.

Syntax

Rhino.SoftEditCurve (strObject, dblParameter, arrDelta, dblDistance [, blnFixEnds [, blnDelete]])

Parameters

strObject

Required.  String.  The identifier of the curve object.

dblParameter

Required.  Number.  The parameter to evaluate. This location on the curve is moved, and the move is smoothly tapered off with increasing distance along the curve from this parameter.

arrDelta

Required.  Array.  A 3-D vector that specifies the direction and the maximum distance of the move.

dblDistance

Required.  Number.  The distance, in model units, along the curve from the editing point over which the strength of the editing falls off smoothly.

blnFixEnds

Optional.  Boolean.  Keeps the position of the curve ends fixed. If False (Default), if dblDistance is larger than the distance to one or both ends of the curve, the end of the curve will be allowed to move. If True, if dblDistance is larger than the distance to one or both ends of the curve, the end of the curve will not be allowed to move.

blnDelete

Optional.  Boolean. Delete the input curve. The default is not delete the input curve (False).

Returns

String

If blnDeleted is True, then the identifier of the modified curve object if successful.

String

If blnDeleted is False, then the identifier of the newly created curve object if successful.

Null

If not successful, or on error.

Example

Dim strCurve, arrPoint0, arrPoint1, arrDelta, dblParam

strCurve = Rhino.GetObject("Select curve", 4)

arrPoint0 = Rhino.GetPointOnCurve(strCurve)

arrPoint1 = Rhino.GetPoint("Length", arrPoint0)

arrDelta = Rhino.VectorCreate(arrPoint1, arrPoint0)

dblParam = Rhino.CurveClosestPoint(strCurve, arrPoint0)

Call Rhino.SoftEditCurve(strCurve, dblParam, arrDelta, 1.0)

Also See

SoftEditSurface