TextObjectFormula

Returns or modifies the text field, or formula, of a text object. Text fields are formulas that are evaluated while Rhino is running and the result is displayed in the text.

Syntax

Rhino.TextObjectFormula (strObject [, strFormula])

Parameters

strObject

Required.  String.  The identifier of the object.

strFormula

Optional.  String.  A new text field, or formula.

Returns

String

If a new formula is not specified,  the current formula value if successful.

String

If a new formula is specified,  the previous formula value if successful.

Null

If not successful, or on error.

Example

Dim strObject, strFormula

strObject = Rhino.GetObject("Select text")

If Rhino.IsText(strObject) Then

  strFormula = Rhino.TextObjectFormula(strObject)

  If Not IsNull(strFormula) Then

    Call Rhino.Print(strFormula)

  End If

End If

Also See

AddText

IsText

TextObjectFont

TextObjectHeight

TextObjectPlane

TextObjectPoint

TextObjectStyle

TextObjectText