SetLayerUserText

Sets or removes user text stored on a layer. For more details on User Text, see the discussion found in the User Data Methods summary.

Syntax

Rhino.SetLayerUserText (strLayer, strKey [, strValue])

Parameters

strLayer

Required.  String.  The name or identifier of an existing layer.

strKey

Required.  String.  The key name to set.

strValue

Optional.  String.  The string value to set. If omitted the key/value pair specified by strKey will be deleted.

Returns

Boolean

True or False indicating success or failure.

Null

If not successful, or on error.

Example

Rhino.SetLayerUserText "First Floor", "Description", "First floor plumbing and electrical"

Rhino.SetLayerUserText "Second Floor", "Description", "Second floor plumbing and electrical"

Also See

GetLayerUserText