DeleteObject

Deletes a single object from the document.

Syntax

Rhino.DeleteObject (strObject [, blnIgnoreModes])

Parameters

strObject

Required.  String.  The identifier of the object to delete.

blnIgnoreModes

Optional.  Boolean.  Allow for a locked or hidden object to be deleted.  The default value is False.

Returns

Boolean

True or false indicating success or failure.

Null

On error.

Example

Dim strObject

strObject = Rhino.GetObject("Select object to delete")

If Not IsNull(strObject) Then

Rhino.DeleteObject strObject

End If

Also See

DeleteObjects