FlowObject

Re-aligns objects from a base curve to a target curve.

Syntax

Rhino.FlowObject (strObject, strCurve0, strCurve1 [, blnReverse0 [, blnReverse1 [, blnStretch [, blnCopy [, blnPreserve]]]]])

Rhino.FlowObject (arrObjects, strCurve0, strCurve1 [, blnReverse0 [, blnReverse1 [, blnStretch [, blnCopy [, blnPreserve]]]]])

Parameters

strObject

Required. String. The identifier of the object to deform.

arrObjects

Required. Array. An array of strings identifying the objects to deform.

strCurve0

Required. String. The identifier of the base curve.

strCurve1

Required. String. The identifier of the target curve.

blnReverse0

Optional. Boolean. Reverse the direction of strCurve0. The default is False.

blnReverse1

Optional. Boolean. Reverse the direction of strCurve1. The default is False.

blnStretch

Optional. Boolean. If False (Default), the length of the objects along the curve directions are not changed. If True, objects are stretched or compressed in the curve direction so that the relationship to the target curve is the same as it is to the base curve.

blnCopy

Optional. Boolean. Copy the objects. If omitted, the objects will not be copied (False).

blnPreserve

Optional.  Boolean. Preserve structure. If False, objects are refit as needed with more control points to allow accurate deformation. If True, the control point structure of the objects are preserved. Deformation may be less accurate if there are too few control points in on the object. The default is False.

Returns

String

The identifier of the deformed object if successful.

Array

An array of strings identifying the deformed objects if successful.

Null

If not successful, or on error.

Example

Dim strObject, strCurve0, strCurve1

strObject = Rhino.GetObject("Select object to flow")

If Not IsNull(strObject) Then

  strCurve0 = Rhino.GetObject("Base curve", 4)

  strCurve1 = Rhino.GetObject("Target curve", 4)

  Rhino.FlowObject strObject, strCurve0, strCurve1

End If

Also See

BendObject

BoxMorphObject

MaelstromObject

StretchObject

TaperObject

TwistObject