RhinoScript Methods

RhinoScript methods fall into one of the following categories.

 

Category

Description

Application Methods

Methods related to the Rhino application.

Block Methods

Methods related to block instances and their definitions.

Curve Methods

Methods related to curve objects.

Dimension Methods

Methods related to dimensions and annotations.

Document Methods

Methods related to the currently open 3DM file.

Geometry Methods

Methods related to geometric objects.

Group Methods

Methods used to manipulate groups of objects.

Hatch Methods

Methods used to manipulate hatch objects.

Layer Methods

Methods used to manipulate layers.

Layer State Methods

Methods used to manipulate layer states.

Light Methods

Methods related to light objects.

Line, Circle, & Plane Methods

Methods related to manipulating 3-D lines and planes.

Linetype Methods

Methods related to linetypes.

Material Methods

Methods related to object rendering materials.

Math Methods

Methods that extent VBScript's math capabilities.

Mesh Methods

Methods related to mesh objects.

Named Position Methods

Methods related to named object positions.

Object Methods

Methods to manipulate general object properties.

Object Grip Methods

Methods for manipulating object grips.

Point & Vector Methods

Methods related to creating and manipulating 3-D points and 3-D vectors.

Selection Methods

Methods for selecting objects or obtaining object identifiers.

Surface and Polysurface Methods

Methods related to surface and polysurface objects.

Toolbar Methods

Methods related to toolbar collections.

Transformation Methods

Methods related to creating transformations.

User Data Methods

Methods related to RhinoScript user data.

User Interface Methods

Methods used to interact with the user.

Utility Methods

Any method that does not fall into any of the above categories.

View Methods

Methods related to manipulate views and construction planes.