NormalObjects

Returns the identifiers of all objects that are neither hidden nor locked in the document, including reference objects.  Normal objects are visible, can be snapped to, and are independent of selection state.

Both the object's hidden and locked status, as well as the object layer's hidden and locked status, are used to determine whether or not the object is returned.

Syntax

Rhino.NormalObjects ([blnIncludeLights [, blnIncludeGrips]])

Parameters

blnIncludeLights

Optional.  Boolean.  Include light objects.  If omitted, light objects are not returned (False).

blnIncludeGrips

Optional.  Boolean.  Include grips objects.  If omitted, grips objects are not returned (False).

Returns

Array

An array of strings identifying the objects if successful.

Null

If not successful, or on error.

Example

Dim arrObjects, strObject

arrObjects = Rhino.NormalObjects

If IsArray(arrObjects) Then

For Each strObject In arrObjects

Rhino.Print "Object identifier: " & strObject

Next

End If

Also See

AllObjects

HiddenObjects

LockedObjects

ReferenceObjects