PointPick

Picks objects using a point selection.

Syntax

Rhino.PointPick (arrPoint [, strView [, blnSelect [, arrAperture [, blnGroup [, arrObjects [, blnUseOsnaps]]]]]])

Parameters

arrPoint

Required.  Array. The 3-D selection point.

strView

Optional.  String.  The title or identifier of the view.  If omitted, the current active view is used.

blnSelect

Optional.  Boolean.  Select picked objects.  If omitted, picked objects are not selected (False).

arrAperture

Optional.  Array.  An array of 2 numbers that identify the x and y values, in pixels, used to inflate the picking aperture.

blnGroup

Optional.  Boolean.  Honor object grouping.  If omitted and the user picks a group, the entire group will be picked (True).

arrObjects

Optional.  Array.  An array of strings identifying the objects that are allowed to be selected.

blnUseOsnaps

Optional.  Boolean.  If True, then the function will attempt to snap to objects using the current object snap settings. If an object snap is successful, then arrPoint is modified to reflect the snap location before attempting to pick objects. If False (Default), then arrPoint is used to pick objects.

Returns

Array

An array that contains arrays of picking information if successful. The array of picking information will contain the following:

Element

Description

0

String. The identifier of the object.

1

Array. The selection point.

Null

If not successful, or on error.

Example

Rhino.PointPick Array(0,0,0), , True

Also See

WindowPick