SmoothSurface

Smooths a surface object by averaging the positions of control points. For more information, see the Rhino help file for the Smooth command.

Syntax

Rhino.SmoothSurface (strObject, dblFactor [, blnXSmooth [, blnYSmooth [, blnZSmooth [, blnFixBoundaries [, intCoordinateSystem [, arrPlane]]]]]])

Parameters

strObject

Required.  String.  The object's identifier.

dblFactor

Required.  Number.  The smoothing factor, which controls how much control points move towards the average of the neighboring points.

blnXSmooth

Optional.  Boolean.  When True (Default) control points move in X-axis direction.

blnYSmooth

Optional.  Boolean.  When True (Default) control points move in Y-axis direction.

blnZSmooth

Optional.  Boolean.  When True (Default) control points move in Z-axis direction.

blnFixBoundaries

Optional.  Boolean.  When True (Default) the curve ends do not move.

intCoordinateSystem

Optional.  Number.  The current coordinate system, where 0 = World (Default), 1 = Construction plane, 2 = Object.

arrPlane

Optional.  Plane.  If intCoordinateSystem = 1, then the construction plane.

Returns

Boolean

True if successful, False otherwise.

Null

On error.

Example

Const RH_SRF = 8

Dim strObject

strObject = Rhino.GetObject("Select a surface to smooth", RH_SRF)

If Rhino.IsSurface(strObject) Then

Call Rhino.SmoothSurface(strObject, 0.2)

End If

Also See

SmoothCurve

SmoothMesh