SoftEditSurface

Moves the surface area surrounding a selected point smoothly relative to the distance from selected point. For more details, see the Rhino help file for the SoftEditSrf command.

Syntax

Rhino.SoftEditSurface (strObject, arrParameter, arrDelta, arrDistance [, blnFixEnds [, blnDelete]])

Parameters

strObject

Required.  String.  The identifier of the surface object.

arrParameter

Required.  Array.  An array containing the U,V parameter to evaluate. This location on the surface is moved, and the move is smoothly tapered off with increasing distance along the surface from this parameter.

arrDelta

Required.  Array.  A 3-D vector that specifies the direction and the maximum distance of the move.

arrDistance

Required.  Array.  An array containing the U,V distances, in model units, influenced by the move.

blnFixEnds

Optional.  Boolean.  Keeps edge locations fixed. The default value is False.

blnDelete

Optional.  Boolean. Delete the input surface . The default is not delete the input surface (False).

Returns

String

If blnDeleted is True, then the identifier of the modified surface object if successful.

String

If blnDeleted is False, then the identifier of the newly created surface object if successful.

Null

If not successful, or on error.

Example

Dim strSurface, arrPoint0, arrPoint1, arrDelta, arrParam

strSurface = Rhino.GetObject("Select surface", 8)

arrPoint0 = Rhino.GetPointOnSurface(strSurface)

arrPoint1 = Rhino.GetPoint("Length", arrPoint0)

arrDelta = Rhino.VectorCreate(arrPoint1, arrPoint0)

arrParam = Rhino.SurfaceClosestPoint(strSurface, arrPoint0)

Call Rhino.SoftEditSurface(strSurface, arrParam, arrDelta, Array(1.0, 1.0))

Also See

SoftEditCurve