SplitSurfaceEx

Splits a surface into pieces using trimming curves.

Syntax

Rhino.SplitSurfaceEx (strSurface, arrCurves [, blnDelete])

Parameters

strSurface

Required.  String.  The identifier of the surface object to split.

strCurve

Required.  String.  The identifier of a curve object to be used as a trimming curve.

arrCurves

Required.  Array.  The identifiers of one or more curve objects to be used as trimming curves.

blnDelete

Optional.  Boolean.  Delete input surface.  If omitted, the input surface will not be deleted (False).

Returns

Array

The identifiers of the new brep objects if successful.

Null

If not successful, or on error.

Example

Dim strSurface, arrCutters

strSurface = Rhino.GetObject("Select surface to split", 8)

arrCutters = Rhino.GetObjects("Select cutting curves", 4)

Rhino.SplitSurfaceEx strSurface, arrCutters

Also See

SplitBrep

SplitSurface

TrimBrep

TrimSurface