SurfaceDivideAlongCreases

Divides a surface or polysurface into separate parts at kinks or tangents.

Syntax

Rhino.SurfaceDivideAlongCreases (strObject, blnSplitAtKinks, blnSplitAtTangents)

Parameters

strObject

Required.  String.  The identifier of the surface or polysurface object.

blnSplitAtKinks

Required.  Boolean.  Specify True to split at kinks.

blnSplitAtTangents

Required.  Boolean.  Specify True to split at tangents.

Returns

Number

The number of faces added, if successful.

Null

If not successful, or on error.

Example

Const RH_SRF = 8

Const RH_POLYSRF = 16

strSurface = Rhino.GetObject("Select surfaces or polysurfaces to divide along creases", RH_SRF + RH_POLYSRF)

If Not IsNull(strSurface) Then

  Call Rhino.SurfaceDivideAlongCreases(strSurface, True, True)

End If

Also See

SplitBrep

SplitSurface

SplitSurfaceEx