UnrollSurface

Flattens (develops) a surface or polysurface to a planar surface. For more information on developable surfaces, see the Rhino help file.

Syntax

Rhino.UnrollSurface (strSurface [, blnExplode [, arrCurves [, arrPoints [, arrDots]]]])

Parameters

strSurface

Required.  String.  The identifier of the surface or polysurface to unroll.

blnExplode

Optional.  Boolean.  If True, then resulting surfaces are not joined. If False (Default), then resulting surfaces are joined along the same edges that were joined in the original polysurface.

arrCurves

Optional.  Array.  The identifiers of curve objects whose geometry you want to follow unrolled surface.  Note, the attributes of these objects will be migrated to the newly created curves.

arrPoints

Optional.  Array.  The identifiers of point objects whose geometry you want to follow unrolled surface.

arrDots

Optional.  Array.  The identifiers of text dot objects whose geometry you want to follow unrolled surface.  Note, the attributes of these objects will be migrated to the newly created text dots.

Returns

Array

The identifiers of the flatten surfaces or polysurfaces, followed by the identifiers of extra curves, points, and text dots, if successful.

Null

If not successful, or on error.

Example

Dim strSurface

strSurface = Rhino.GetObject("Select surface or polysurface to unroll", 8 + 16)

If Not IsNull(strSurface) Then

  Rhino.UnrollSurface strSurface

End If

Also See

IsSurfaceUnrollable