EditListBox

Displays a sizeable Windows dialog box with an editable list box. Items can be added or removed from the list, and the order of the list can be changed.

Syntax

Rhino.EditListBox (arrItems [, strMessage [, strTitle [, arrPos]]])

Parameters

arrItems

Required.  Array.  An array of strings.

strMessage

Optional.  String.  A prompt or message.

strTitle

Optional.  String.  A dialog box title.

arrPos

Optional.  Array.  A 2-D screen point that identifies the upper left corner of the dialog's initial position.

Returns

Array

The strings if successful.

Null

If not successful, or on error.

Example

Dim arrItems, arrResults, strItem

arrItems = Array("Item0", "Item1", "Item2", "Item3")

arrResults = Rhino.EditListbox(arrItems, "Add, remove, or edit items", "Edit Items")

If IsArray(arrResults) Then

  For Each strItem in arrResults

    Rhino.Print strItem

  Next

End If

editlistbox.jpg

Also See

CheckListBox

ComboListBox

ListBox

MultiListBox

OrderListBox

PropertyListBox