GetBaseClassAddOptionColor Method (LocalizeStringPair, OptionColor, String) |
Add a command line option to get colors and automatically save the value.
Namespace:
Rhino.Input.Custom
Assembly:
RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntaxpublic int AddOptionColor(
LocalizeStringPair optionName,
ref OptionColor colorValue,
string prompt
)
Public Function AddOptionColor (
optionName As LocalizeStringPair,
ByRef colorValue As OptionColor,
prompt As String
) As Integer
Parameters
- optionName
- Type: Rhino.UILocalizeStringPair
option description. - colorValue
- Type: Rhino.Input.CustomOptionColor
The current color value. - prompt
- Type: SystemString
option prompt shown if the user selects this option
Return Value
Type:
Int32option index value (>0) or 0 if option cannot be added.
See Also