RhinoCommon API
RhinoCommon API
Namespaces
Rhino.Input.Custom
GetBaseClass Class
GetBaseClass Methods
AcceptColor Method
AcceptCustomMessage Method
AcceptEnterWhenDone Method
AcceptNothing Method
AcceptNumber Method
AcceptPoint Method
AcceptString Method
AcceptUndo Method
AddOption Method
AddOptionColor Method
AddOptionDouble Method
AddOptionEnumList Method
AddOptionEnumSelectionList(T) Method
AddOptionInteger Method
AddOptionList Method
AddOptionToggle Method
ClearCommandOptions Method
ClearDefault Method
Color Method
CommandResult Method
CustomMessage Method
Dispose Method
EnableTransparentCommands Method
Finalize Method
GetSelectedEnumValue(T) Method
GetSelectedEnumValueFromSelectionList(T) Method
GotDefault Method
Line2d Method
Number Method
Option Method
OptionIndex Method
PickRectangle Method
Point Method
Point2d Method
PostCustomMessage Method
Rectangle2d Method
Result Method
SetCommandPrompt Method
SetCommandPromptDefault Method
SetDefaultColor Method
SetDefaultInteger Method
SetDefaultNumber Method
SetDefaultPoint Method
SetDefaultString Method
SetWaitDuration Method
StringResult Method
Vector Method
View Method
GetBaseClass
Color Method
Gets a color if Get*() returns GetResult.Color.
Namespace:
Rhino.Input.Custom
Assembly:
RhinoCommon (in RhinoCommon.dll)
Since:
5.0
Syntax
C#
VB
Copy
public
Color
Color
()
Public
Function
Color
As
Color
Return Value
Type:
Color
The color chosen by the user.
See Also
Reference
GetBaseClass Class
Rhino.Input.Custom Namespace
Rhino 7.26.23009.07000 (2023-01-09)
Copyright © 2009-2023 Robert McNeel & Associates
Report wishes and bugs at discourse.mcneel.com