ReplayHistoryData Class |
Namespace: Rhino.DocObjects
The ReplayHistoryData type exposes the following members.
Name | Description | |
---|---|---|
![]() | Document | The document this record belongs to |
![]() | HistoryVersion |
ReplayHistory overrides check the version number to ensure the information
saved in the history record is compatible with the current implementation
of ReplayHistory
|
![]() | RecordId |
Each history record has a unique id that Rhino assigns when it adds the
history record to the history record table
|
![]() | Results |
Provides access to BOTH inputs and outputs of the replay history operation.
Use this property to then call an appropriate UpdateToX() method and make your custom history support work. |
Name | Description | |
---|---|---|
![]() | Dispose | Releases all resources used by the ReplayHistoryData |
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.) |
![]() | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.) |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object.) |
![]() | GetRhinoObjRef |
In ReplayHistory, use GetRhinoObjRef to convert the information
in a history record into the ObjRef that has up to date
RhinoObject pointers
|
![]() | GetType | Gets the Type of the current instance. (Inherited from Object.) |
![]() | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.) |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object.) |
![]() | TryGetBool | |
![]() | TryGetColor | |
![]() | TryGetDouble | |
![]() | TryGetDoubles | |
![]() | TryGetGuid | |
![]() | TryGetInt | |
![]() | TryGetPoint3d | |
![]() | TryGetPoint3dOnObject | |
![]() | TryGetString | |
![]() | TryGetTransform | |
![]() | TryGetVector3d |