CommandLineOption Class |
[Missing <summary> documentation for "T:Rhino.Input.Custom.CommandLineOption"]
Namespace: Rhino.Input.Custom
The CommandLineOption type exposes the following members.
Name | Description | |
---|---|---|
![]() ![]() | CurrentListOptionIndex | |
![]() | EnglishName |
The English command option name
|
![]() | Index | |
![]() | LocalName |
The localized command option name
|
![]() | StringOptionValue |
Assigned by RhinoGet.Get if an option value is specified in a script or by a command window control.
|
Name | Description | |
---|---|---|
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.) |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object.) |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object.) |
![]() ![]() | IsValidOptionName |
Test a string to see if it can be used as an option name in any of the RhinoGet::AddCommandOption...() functions.
|
![]() ![]() | IsValidOptionValueName |
Test a string to see if it can be used as an option value in RhinoGet::AddCommandOption,
RhinoGet::AddCommandOptionToggle, or RhinoGet::AddCommandOptionList.
|
![]() | ToString | Returns a string that represents the current object. (Inherited from Object.) |