GroundPlane Class |
Namespace: Rhino.Render
The GroundPlane type exposes the following members.
Name | Description | |
---|---|---|
![]() | GroundPlane |
Create an utility object not associated with any document
|
![]() | GroundPlane(GroundPlane) |
Create an utility object not associated with any document from another object
|
Name | Description | |
---|---|---|
![]() | Altitude |
Height above world XY plane in model units.
|
![]() | AutoAltitude |
Determines whether the ground plane is fixed by the Altitude property, or whether it is automatically placed at the lowest point in the model.
|
![]() | Enabled |
Determines whether the document ground plane is enabled.
|
![]() | MaterialInstanceId |
Id of material in material table for this ground plane.
|
![]() | ShadowOnly |
Determines whether the ground plane shows the material assigned, or whether it is transparent, but captures shadows.
|
![]() | ShowUnderside |
If this is off, the ground plane will not be visible when seen from below.
|
![]() | TextureOffset |
Texture mapping offset in world units.
|
![]() | TextureOffsetLocked |
Texture offset locked.
|
![]() | TextureRotation |
Texture mapping rotation around world origin + offset in degrees.
|
![]() | TextureSize |
Texture mapping single UV span size in world units.
|
![]() | TextureSizeLocked |
Texture size locked.
|
Name | Description | |
---|---|---|
![]() | BeginChange |
Call this function before making any change to this object (calling a setter) otherwise undo will not work correctly. Calls to BeginChange must be paired with a call to EndChange.
(Inherited from DocumentOrFreeFloatingBase.) |
![]() | CopyFrom | (Overrides FreeFloatingBaseCopyFrom(FreeFloatingBase).) |
![]() | EndChange |
See BeginChange
(Inherited from DocumentOrFreeFloatingBase.) |
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.) |
![]() | Finalize |
Handle destruction of the un-managed CPP object.
(Inherited from FreeFloatingBase.) |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object.) |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object.) |
![]() | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.) |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object.) |