Rhino C++ API
8.18
Main Page
Related Pages
Modules
Classes
Class List
Class Index
Class Hierarchy
Class Members
All
_
a
b
c
d
e
f
g
h
i
j
k
l
m
n
o
p
q
r
s
t
u
v
w
x
y
z
~
Functions
_
a
b
c
d
e
f
g
h
i
j
k
l
m
n
o
p
q
r
s
t
u
v
w
x
y
z
~
Variables
_
a
b
c
d
e
f
g
h
i
j
k
l
m
n
o
p
q
r
s
t
u
v
w
x
y
z
Typedefs
Enumerations
a
b
c
d
e
f
g
h
i
k
l
m
n
o
p
q
r
s
t
u
v
w
Enumerator
a
b
c
d
e
f
g
h
i
j
k
l
m
n
o
p
q
r
s
t
u
v
w
x
y
z
Related Functions
c
d
g
i
o
q
r
s
t
•
All
Classes
Namespaces
Functions
Variables
Typedefs
Enumerations
Enumerator
Friends
Modules
Pages
CRhRdkContentIOPlugIn Member List
This is the complete list of members for
CRhRdkContentIOPlugIn
, including all inherited members.
CanLoad
(void) const =0
CRhRdkContentIOPlugIn
pure virtual
CanSave
(void) const =0
CRhRdkContentIOPlugIn
pure virtual
CheckMemory
(void)
CRhRdkObject
static
CRhRdkExtension
()
CRhRdkExtension
CRhRdkObject
()
CRhRdkObject
Description
(void) const =0
CRhRdkContentIOPlugIn
pure virtual
EVF
(const wchar_t *, void *) override
CRhRdkContentIOPlugIn
inline
virtual
FileExtension
(void) const =0
CRhRdkContentIOPlugIn
pure virtual
InterfaceId
(void) const override
CRhRdkContentIOPlugIn
virtual
Kind
(void) const
CRhRdkContentIOPlugIn
inline
virtual
Load
(const CRhinoDoc *pDoc, const wchar_t *wszFullPath, CRhRdkContent::Kinds kind) const =0
CRhRdkContentIOPlugIn
pure virtual
operator delete
(void *buf)
CRhRdkObject
operator delete[]
(void *buf)
CRhRdkObject
operator new
(size_t size)
CRhRdkObject
operator new[]
(size_t size)
CRhRdkObject
PlugInId
(void) const =0
CRhRdkExtension
pure virtual
PopulateDebuggingInfo
(void)
CRhRdkObject
static
RdkPlugInId
(void) const =0
CRhRdkContentIOPlugIn
pure virtual
Save
(const wchar_t *wszFullPath, const CRhRdkContent &content, const IRhRdkPreviewSceneServer *pSceneServer) const =0
CRhRdkContentIOPlugIn
pure virtual
SupportedKinds
(void) const =0
CRhRdkContentIOPlugIn
pure virtual
Unregister
(void)
CRhRdkExtension
~CRhRdkExtension
()
CRhRdkExtension
virtual
~CRhRdkObject
()
CRhRdkObject
virtual
Generated on Tue Apr 8 2025 16:23:57 for Rhino C++ API by
1.8.17