Rhino C++ API
8.18
|
#include <RhRdkTwoColorTextureBase.h>
Public Member Functions | |
CRhRdkOneColorTextureBaseCSI (const CRhRdkContent *pContent, CRhRdkContent::CSIContext context) | |
virtual | ~CRhRdkOneColorTextureBaseCSI () |
virtual bool | NextChildSlot (ON_wString &sParamNameOut, ON_wString &sChildSlotNameOut, ON_wString &sDisplayNameOut) |
![]() | |
CChildSlotIterator (const CRhRdkContent *pContent, CRhRdkContent::CSIContext context) | |
virtual | ~CChildSlotIterator () |
virtual void * | EVF (const wchar_t *wszFunc, void *pvData) |
![]() | |
CRhRdkObject () | |
virtual | ~CRhRdkObject () |
void | operator delete (void *buf) |
void | operator delete[] (void *buf) |
void * | operator new (size_t size) |
void * | operator new[] (size_t size) |
Protected Member Functions | |
virtual void | IncIndex (void) |
virtual int | Index (void) const |
Additional Inherited Members | |
![]() | |
static void | CheckMemory (void) |
static void | PopulateDebuggingInfo (void) |
![]() | |
CRhRdkContent::CSIContext | m_Context |
const CRhRdkContent * | m_pContent |
ON__UINT_PTR | m_reserved |
CRhRdkOneColorTextureBaseCSI::CRhRdkOneColorTextureBaseCSI | ( | const CRhRdkContent * | pContent, |
CRhRdkContent::CSIContext | context | ||
) |
|
virtual |
|
protectedvirtual |
Increments the iterator index.
|
protectedvirtual |
|
virtual |
If you override this you must call the base class first and return true if the base class returns true. Otherwise call Index() and return your child slots based on the returned index value; remember to call IncIndex() before you return true. When you have no more child slots to return, return false.
Implements CRhRdkContent::CChildSlotIterator.
Reimplemented in CRhRdkTwoColorTextureBaseCSI.