Rhino C++ API
8.18
Main Page
Related Pages
Modules
Classes
Class List
Class Index
Class Hierarchy
Class Members
All
_
a
b
c
d
e
f
g
h
i
j
k
l
m
n
o
p
q
r
s
t
u
v
w
x
y
z
~
Functions
_
a
b
c
d
e
f
g
h
i
j
k
l
m
n
o
p
q
r
s
t
u
v
w
x
y
z
~
Variables
_
a
b
c
d
e
f
g
h
i
j
k
l
m
n
o
p
q
r
s
t
u
v
w
x
y
z
Typedefs
Enumerations
a
b
c
d
e
f
g
h
i
k
l
m
n
o
p
q
r
s
t
u
v
w
Enumerator
a
b
c
d
e
f
g
h
i
j
k
l
m
n
o
p
q
r
s
t
u
v
w
x
y
z
Related Functions
c
d
g
i
o
q
r
s
t
•
All
Classes
Namespaces
Functions
Variables
Typedefs
Enumerations
Enumerator
Friends
Modules
Pages
CRhRdkTextureCache Member List
This is the complete list of members for
CRhRdkTextureCache
, including all inherited members.
AddTexture
(const CRhinoDib &dib)
CRhRdkTextureCache
virtual
AddTexture
(const CRhinoDib &dib, Location locationsToAddTo)
CRhRdkTextureCache
CheckMemory
(void)
CRhRdkObject
static
CRhRdkObject
()
CRhRdkObject
CRhRdkTextureCache
(const ON_2iSize &size, DWORD dwCRC)
CRhRdkTextureCache
CRhRdkTextureCache
(const ON_2iSize &size, DWORD dwCRC, const wchar_t *wszTag)
CRhRdkTextureCache
EVF
(const wchar_t *wszFunc, void *pvData)
CRhRdkObject
virtual
Filename
(void) const
CRhRdkTextureCache
virtual
Filename
(Location locationFileIsExpected) const
CRhRdkTextureCache
HasCachedTexture
(void) const
CRhRdkTextureCache
virtual
HasCachedTexture
(Location locationsToCheck) const
CRhRdkTextureCache
Lock
() const
CRhRdkTextureCache
operator delete
(void *buf)
CRhRdkObject
operator delete[]
(void *buf)
CRhRdkObject
operator new
(size_t size)
CRhRdkObject
operator new[]
(size_t size)
CRhRdkObject
PopulateDebuggingInfo
(void)
CRhRdkObject
static
Unlock
() const
CRhRdkTextureCache
~CRhRdkObject
()
CRhRdkObject
virtual
~CRhRdkTextureCache
()
CRhRdkTextureCache
virtual
Generated on Tue Apr 8 2025 16:24:00 for Rhino C++ API by
1.8.17