Rhino C++ API
8.18
|
#include <RhRdkTwoColorTextureBase.h>
Public Member Functions | |
CRhRdkTwoColorTextureBaseCSI (const CRhRdkContent *pContent, CRhRdkContent::CSIContext context) | |
virtual | ~CRhRdkTwoColorTextureBaseCSI () |
virtual bool | NextChildSlot (ON_wString &sParamNameOut, ON_wString &sChildSlotNameOut, ON_wString &sDisplayNameOut) |
![]() | |
CRhRdkOneColorTextureBaseCSI (const CRhRdkContent *pContent, CRhRdkContent::CSIContext context) | |
virtual | ~CRhRdkOneColorTextureBaseCSI () |
![]() | |
CChildSlotIterator (const CRhRdkContent *pContent, CRhRdkContent::CSIContext context) | |
virtual | ~CChildSlotIterator () |
virtual void * | EVF (const wchar_t *wszFunc, void *pvData) |
![]() | |
CRhRdkObject () | |
virtual | ~CRhRdkObject () |
void | operator delete (void *buf) |
void | operator delete[] (void *buf) |
void * | operator new (size_t size) |
void * | operator new[] (size_t size) |
Additional Inherited Members | |
![]() | |
static void | CheckMemory (void) |
static void | PopulateDebuggingInfo (void) |
![]() | |
virtual void | IncIndex (void) |
virtual int | Index (void) const |
![]() | |
CRhRdkContent::CSIContext | m_Context |
const CRhRdkContent * | m_pContent |
ON__UINT_PTR | m_reserved |
CRhRdkTwoColorTextureBaseCSI::CRhRdkTwoColorTextureBaseCSI | ( | const CRhRdkContent * | pContent, |
CRhRdkContent::CSIContext | context | ||
) |
|
virtual |
|
virtual |
If you override this you must call the base class first and return true if the base class returns true. Otherwise call Index() and return your child slots based on the returned index value; remember to call IncIndex() before you return true. When you have no more child slots to return, return false.
Reimplemented from CRhRdkOneColorTextureBaseCSI.