Rhino C++ API
8.18
Main Page
Related Pages
Modules
Classes
Class List
Class Index
Class Hierarchy
Class Members
All
_
a
b
c
d
e
f
g
h
i
j
k
l
m
n
o
p
q
r
s
t
u
v
w
x
y
z
~
Functions
_
a
b
c
d
e
f
g
h
i
j
k
l
m
n
o
p
q
r
s
t
u
v
w
x
y
z
~
Variables
_
a
b
c
d
e
f
g
h
i
j
k
l
m
n
o
p
q
r
s
t
u
v
w
x
y
z
Typedefs
Enumerations
a
b
c
d
e
f
g
h
i
k
l
m
n
o
p
q
r
s
t
u
v
w
Enumerator
a
b
c
d
e
f
g
h
i
j
k
l
m
n
o
p
q
r
s
t
u
v
w
x
y
z
Related Functions
c
d
g
i
o
q
r
s
t
•
All
Classes
Namespaces
Functions
Variables
Typedefs
Enumerations
Enumerator
Friends
Modules
Pages
CRhinoGumballSizes Member List
This is the complete list of members for
CRhinoGumballSizes
, including all inherited members.
Compare
(const CRhinoGumballSizes &a, const CRhinoGumballSizes &b)
CRhinoGumballSizes
static
CRhinoGumballSizes
()
CRhinoGumballSizes
default_arc_thickness
CRhinoGumballSizes
static
default_axis_thickness
CRhinoGumballSizes
static
default_extrude_ball_size
CRhinoGumballSizes
static
default_gumball_ptran_angle
CRhinoGumballSizes
static
default_gumball_ptran_dist
CRhinoGumballSizes
static
default_gumball_ptran_size
CRhinoGumballSizes
static
default_gumball_radius
CRhinoGumballSizes
static
default_gumball_tail_size
CRhinoGumballSizes
static
default_gumball_tip_length
CRhinoGumballSizes
static
default_gumball_tip_width
CRhinoGumballSizes
static
default_menu_dist
CRhinoGumballSizes
static
default_menu_size
CRhinoGumballSizes
static
GetWorldRadius
(const ON_Viewport &viewport, const ON_3dPoint ¢er, double *world_radius) const
CRhinoGumballSizes
m_arc_thickness
CRhinoGumballSizes
m_axis_thickness
CRhinoGumballSizes
m_extrude_ball_size
CRhinoGumballSizes
m_gumball_ptran_angle
CRhinoGumballSizes
m_gumball_ptran_dist
CRhinoGumballSizes
m_gumball_ptran_size
CRhinoGumballSizes
m_gumball_radius
CRhinoGumballSizes
m_gumball_tail_size
CRhinoGumballSizes
m_gumball_tip_length
CRhinoGumballSizes
m_gumball_tip_width
CRhinoGumballSizes
m_menu_dist
CRhinoGumballSizes
m_menu_size
CRhinoGumballSizes
operator!=
(const CRhinoGumballSizes &) const
CRhinoGumballSizes
operator==
(const CRhinoGumballSizes &) const
CRhinoGumballSizes
Read
(ON_BinaryArchive &binary_archive)
CRhinoGumballSizes
Read
(LPCTSTR lpszSection, CRhinoProfileContext &pc)
CRhinoGumballSizes
Reset
()
CRhinoGumballSizes
SetToDefaultSizes
()
CRhinoGumballSizes
SetToFactorySizes
()
CRhinoGumballSizes
Write
(ON_BinaryArchive &binary_archive) const
CRhinoGumballSizes
Write
(LPCTSTR lpszSection, CRhinoProfileContext &pc) const
CRhinoGumballSizes
Generated on Tue Apr 8 2025 16:23:50 for Rhino C++ API by
1.8.17