Rhino C++ API  8.6
ON_NurbsCurve Member List

This is the complete list of members for ON_NurbsCurve, including all inherited members.

AggregateComponentStatus() constON_Objectvirtual
Append(const ON_NurbsCurve &)ON_NurbsCurve
AreaMassProperties(ON_3dPoint base_point, ON_3dVector plane_normal, ON_MassProperties &mp, bool bArea=true, bool bFirstMoments=true, bool bSecondMoments=true, bool bProductMoments=true, double rel_tol=1.0e-6, double abs_tol=1.0e-6) constON_Curve
AttachUserData(class ON_UserData *pUserData)ON_Object
BoundingBox() constON_Geometry
BrepForm(class ON_Brep *brep=nullptr) constON_Geometryvirtual
ChangeClosedCurveSeam(double t) overrideON_NurbsCurvevirtual
ON_Curve::ChangeClosedCurveSeam(double t, double min_dist)ON_Curve
ChangeDimension(int desired_dimension) overrideON_NurbsCurvevirtual
ChangeEndWeights(double w0, double w1)ON_NurbsCurve
ClampEnd(int end)ON_NurbsCurve
ClearAllComponentStates() constON_Object
ClearBoundingBox()ON_Geometryvirtual
ClearComponentStates(ON_ComponentStatus states_to_clear) constON_Objectvirtual
ClearComponentStates(ON_COMPONENT_INDEX component_index, ON_ComponentStatus states_to_clear) constON_Objectvirtual
ComponentIndex() constON_Geometryvirtual
ControlPoint(int cv_index) constON_NurbsCurve
ControlPolygonLength() constON_NurbsCurve
ConvertSpanToBezier(int, ON_BezierCurve &) constON_NurbsCurve
CopyUserData(const ON_Object &source_object, ON_UUID source_userdata_item_id, ON_Object::UserDataConflictResolution userdata_conflict_resolution)ON_Object
CopyUserData(const ON_Object &source_object)ON_Object
Create(int dimension, bool bIsRational, int order, int cv_count)ON_NurbsCurve
CreateClampedUniformNurbs(int dimension, int order, int point_count, const ON_3dPoint *point, double knot_delta=1.0)ON_NurbsCurve
CreateCubicLoft(int point_count, int point_dim, int point_stride, const double *point_list, double k, int is_closed=0, ON::cubic_loft_end_condition start_shape=ON::cubic_loft_ec_quadratic, ON::cubic_loft_end_condition end_shape=ON::cubic_loft_ec_quadratic, class ON_NurbsCurve *nurbs_curve=0)ON_Curvestatic
CreateCurveTree() constON_Curvevirtual
CreatePeriodicUniformNurbs(int dimension, int order, int point_count, const ON_3dPoint *point, double knot_delta=1.0)ON_NurbsCurve
CurvatureAt(double t) constON_Curve
CurveTree() constON_Curve
CV(int cv_index) constON_NurbsCurve
CVCapacity() constON_NurbsCurve
CVCount(void) constON_NurbsCurve
CVSize(void) constON_NurbsCurve
CVStyle() constON_NurbsCurve
DataCRC(ON__UINT32 current_remainder) const overrideON_NurbsCurvevirtual
Degree() const overrideON_NurbsCurvevirtual
DeleteComponents(const ON_COMPONENT_INDEX *ci_list, size_t ci_count)ON_Objectvirtual
DerivativeAt(double t) constON_Curve
Destroy()ON_NurbsCurve
DestroyCurveTree()ON_Curve
DestroyRuntimeCache(bool bDelete=true) overrideON_Curvevirtual
DetachUserData(class ON_UserData *pUserData)ON_Object
Dimension() const overrideON_NurbsCurvevirtual
Domain() const overrideON_NurbsCurvevirtual
Dump(ON_TextLog &dump) const overrideON_NurbsCurvevirtual
DuplicateCurve() constON_Curvevirtual
EmergencyDestroy()ON_NurbsCurve
Ev1Der(double t, ON_3dPoint &point, ON_3dVector &first_derivative, int side=0, int *hint=0) constON_Curve
Ev2Der(double t, ON_3dPoint &point, ON_3dVector &first_derivative, ON_3dVector &second_derivative, int side=0, int *hint=0) constON_Curve
Evaluate(double, int, int, double *, int=0, int *=0) const overrideON_NurbsCurvevirtual
EvaluatePoint(const class ON_ObjRef &objref, ON_3dPoint &P) const overrideON_Curvevirtual
EvCurvature(double t, ON_3dPoint &point, ON_3dVector &tangent, ON_3dVector &kappa, int side=0, int *hint=0) constON_Curve
EvPoint(double t, ON_3dPoint &point, int side=0, int *hint=0) constON_Curve
EvSignedCurvature(double t, ON_3dPoint &point, ON_3dVector &tangent, double &kappa, const ON_3dVector *normal=nullptr, int side=0, int *hint=0) constON_Curve
EvTangent(double t, ON_3dPoint &point, ON_3dVector &tangent, int side=0, int *hint=0) constON_Curve
Extend(const ON_Interval &domain) overrideON_NurbsCurvevirtual
FirstSpanIsLinear(double min_length, double tolerance) constON_Curve
FirstSpanIsLinear(double min_length, double tolerance, ON_Line *span_line) constON_Curve
FirstUserData() constON_Object
FrameAt(double t, ON_Plane &plane) constON_Curve
GetBBox(double *boxmin, double *boxmax, bool bGrowBox=false) const overrideON_NurbsCurvevirtual
GetBoundingBox(ON_BoundingBox &bbox, bool bGrowBox=false) constON_Geometry
GetBoundingBox(ON_3dPoint &bbox_min, ON_3dPoint &bbox_max, bool bGrowBox=false) constON_Geometry
GetClosestPoint(const ON_3dPoint &, double *t, double maximum_distance=0.0, const ON_Interval *sub_domain=nullptr) const overrideON_NurbsCurvevirtual
GetComponentsWithSetStates(ON_ComponentStatus states_filter, bool bAllEqualStates, ON_SimpleArray< ON_COMPONENT_INDEX > &components) constON_Objectvirtual
GetCubicBezierApproximation(double max_deviation, class ON_BezierCurve &bezierCurve) constON_NurbsCurve
GetCubicBezierApproximation(double max_deviation, ON_3dPoint bezCV[4]) constON_NurbsCurve
GetCurveParameterFromNurbFormParameter(double nurbs_t, double *curve_t) const overrideON_NurbsCurvevirtual
GetCV(int, ON::point_style, double *) constON_NurbsCurve
GetCV(int, ON_3dPoint &) constON_NurbsCurve
GetCV(int, ON_4dPoint &) constON_NurbsCurve
GetDomain(double *t0, double *t1) constON_Curve
GetGrevilleAbcissae(double *) constON_NurbsCurve
GetLength(double *length, double fractional_tolerance=1.0e-8, const ON_Interval *sub_domain=nullptr) constON_Curvevirtual
GetLocalClosestPoint(const ON_3dPoint &test_point, double seed_parameter, double *t, const ON_Interval *sub_domain=0) constON_Curvevirtual
GetNextDiscontinuity(ON::continuity c, double t0, double t1, double *t, int *hint=nullptr, int *dtype=nullptr, double cos_angle_tolerance=ON_DEFAULT_ANGLE_TOLERANCE_COSINE, double curvature_tolerance=ON_SQRT_EPSILON) const overrideON_NurbsCurvevirtual
GetNormalizedArcLengthPoint(double s, double *t, double fractional_tolerance=1.0e-8, const ON_Interval *sub_domain=nullptr) constON_Curvevirtual
GetNormalizedArcLengthPoints(int count, const double *s, double *t, double absolute_tolerance=0.0, double fractional_tolerance=1.0e-8, const ON_Interval *sub_domain=nullptr) constON_Curvevirtual
GetNurbForm(ON_NurbsCurve &nurbsform, double tolerance=0.0, const ON_Interval *subdomain=nullptr) const overrideON_NurbsCurvevirtual
GetNurbFormParameterFromCurveParameter(double curve_t, double *nurbs_t) const overrideON_NurbsCurvevirtual
GetParameterTolerance(double t, double *tminus, double *tplus) const overrideON_NurbsCurvevirtual
GetSpanVector(double *knot_values) const overrideON_NurbsCurvevirtual
GetSpanVectorIndex(double t, int side, int *span_vector_index, ON_Interval *span_domain) constON_Curvevirtual
GetTightBoundingBox(class ON_BoundingBox &tight_bbox, bool bGrowBox=false, const class ON_Xform *xform=nullptr) const overrideON_Curvevirtual
GetUserData(const ON_UUID &userdata_uuid) constON_Object
GetUserString(const wchar_t *key, ON_wString &string_value) constON_Object
GetUserStringKeys(ON_ClassArray< ON_wString > &user_string_keys) constON_Object
GetUserStrings(ON_ClassArray< ON_UserString > &user_strings) constON_Object
GrevilleAbcissa(int) constON_NurbsCurve
GrevilleInterpolate(const ON_SimpleArray< ON_3dPoint > &points, bool bPeriodic)ON_NurbsCurve
GrevilleInterpolate(const double *points, size_t point_count, size_t point_stride, bool bPeriodic)ON_NurbsCurve
GrevilleInterpolate(const double *points, size_t point_count, size_t point_stride, bool bPeriodic, int cv0, int cv1)ON_NurbsCurve
GrevilleInterpolate(const ON_SimpleArray< ON_3dPoint > &points, bool bPeriodic, int cv0, int cv1)ON_NurbsCurve
HasBezierSpans() constON_NurbsCurve
HasBrepForm() constON_Geometryvirtual
HasNurbForm() const overrideON_NurbsCurvevirtual
IncreaseDegree(int desired_degree)ON_NurbsCurve
Initialize(void)ON_NurbsCurve
InsertKnot(double knot_value, int knot_multiplicity)ON_NurbsCurve
IntersectCurve(const ON_Curve *curveB, ON_SimpleArray< ON_X_EVENT > &x, double intersection_tolerance=0.0, double overlap_tolerance=0.0, const ON_Interval *curveA_domain=0, const ON_Interval *curveB_domain=0) constON_Curve
IntersectPlane(ON_PlaneEquation plane_equation, ON_SimpleArray< ON_X_EVENT > &x, double intersection_tolerance=0.0, double overlap_tolerance=0.0, const ON_Interval *curve_domain=0) constON_Curve
IntersectSelf(ON_SimpleArray< ON_X_EVENT > &x, double intersection_tolerance=0.0, const ON_Interval *curve_domain=0) constON_Curvevirtual
IntersectSurface(const ON_Surface *surfaceB, ON_SimpleArray< ON_X_EVENT > &x, double intersection_tolerance=0.0, double overlap_tolerance=0.0, const ON_Interval *curveA_domain=0, const ON_Interval *surfaceB_udomain=0, const ON_Interval *surfaceB_vdomain=0) constON_Curve
IsArc(const ON_Plane *plane=nullptr, ON_Arc *arc=nullptr, double tolerance=ON_ZERO_TOLERANCE) const overrideON_NurbsCurvevirtual
IsArcAt(double t, const ON_Plane *plane=0, ON_Arc *arc=0, double tolerance=ON_ZERO_TOLERANCE, double *t0=0, double *t1=0) constON_Curve
IsClamped(int end=2) constON_NurbsCurve
IsClosable(double tolerance, double min_abs_size=0.0, double min_rel_size=10.0) constON_Curve
IsClosed() const overrideON_NurbsCurvevirtual
IsContinuous(ON::continuity c, double t, int *hint=nullptr, double point_tolerance=ON_ZERO_TOLERANCE, double d1_tolerance=ON_ZERO_TOLERANCE, double d2_tolerance=ON_ZERO_TOLERANCE, double cos_angle_tolerance=ON_DEFAULT_ANGLE_TOLERANCE_COSINE, double curvature_tolerance=ON_SQRT_EPSILON) const overrideON_NurbsCurvevirtual
IsCorrupt(bool bRepair, bool bSilentError, class ON_TextLog *text_log) constON_Object
IsDeformable() const overrideON_NurbsCurvevirtual
IsDuplicate(const ON_NurbsCurve &other, bool bIgnoreParameterization, double tolerance=ON_ZERO_TOLERANCE) constON_NurbsCurve
IsEllipse(const ON_Plane *plane=nullptr, ON_Ellipse *ellipse=nullptr, double tolerance=ON_ZERO_TOLERANCE) constON_Curvevirtual
IsInPlane(const ON_Plane &test_plane, double tolerance=ON_ZERO_TOLERANCE) const overrideON_NurbsCurvevirtual
IsKindOf(const ON_ClassId *pClassId) constON_Object
IsLinear(double tolerance=ON_ZERO_TOLERANCE) const overrideON_NurbsCurvevirtual
IsMorphable() const overrideON_NurbsCurvevirtual
IsNatural(int end=2) constON_NurbsCurve
IsPeriodic() const overrideON_NurbsCurvevirtual
IsPlanar(ON_Plane *plane=nullptr, double tolerance=ON_ZERO_TOLERANCE) const overrideON_NurbsCurvevirtual
IsPolyline(ON_SimpleArray< ON_3dPoint > *pline_points=nullptr, ON_SimpleArray< double > *pline_t=nullptr) const overrideON_NurbsCurvevirtual
IsRational(void) constON_NurbsCurve
IsShort(double tolerance, const ON_Interval *sub_domain=0, double *length_estimate=0) const overrideON_NurbsCurvevirtual
IsSingular() constON_NurbsCurve
IsSubDFriendly(bool bPermitCreases) constON_NurbsCurve
IsValid(class ON_TextLog *text_log=nullptr) const overrideON_NurbsCurvevirtual
Knot(int knot_index) constON_NurbsCurve
Knot() constON_NurbsCurve
KnotCapacity() constON_NurbsCurve
KnotCount(void) constON_NurbsCurve
KnotMultiplicity(int knot_index) constON_NurbsCurve
LastSpanIsLinear(double min_length, double tolerance) constON_Curve
LastSpanIsLinear(double min_length, double tolerance, ON_Line *span_line) constON_Curve
LengthMassProperties(class ON_MassProperties &mp, bool bLength=true, bool bFirstMoments=true, bool bSecondMoments=true, bool bProductMoments=true, double rel_tol=1.0e-6, double abs_tol=1.0e-6) constON_Curve
m_cvON_NurbsCurve
m_cv_capacityON_NurbsCurve
m_cv_countON_NurbsCurve
m_cv_strideON_NurbsCurve
m_dimON_NurbsCurve
m_is_ratON_NurbsCurve
m_knotON_NurbsCurve
m_orderON_NurbsCurve
MakeClampedUniformKnotVector(double delta=1.0)ON_NurbsCurve
MakeDeformable() overrideON_NurbsCurvevirtual
MakeNonRational()ON_NurbsCurve
MakePeriodicUniformKnotVector(double delta=1.0)ON_NurbsCurve
MakePiecewiseBezier(bool bSetEndWeightsToOne=false)ON_NurbsCurve
MakeRational()ON_NurbsCurve
ManageKnotForExperts(int knot_capacity, double *knot)ON_NurbsCurve
MarkAggregateComponentStatusAsNotCurrent() constON_Objectvirtual
MemoryRelocate()ON_Objectvirtual
MeshCurve(ON_MeshCurveParameters &mp, ON_PolylineCurve *polyline, bool bSkipFirstPoint, const ON_Interval *domain) constON_Curve
ModelObjectId() constON_Objectvirtual
Morph(const ON_SpaceMorph &morph) overrideON_NurbsCurve
ON_Curve::Morph(const class ON_SpaceMorph &morph)ON_Geometryvirtual
MoveUserData(ON_Object &source_object, ON_UUID source_userdata_item_id, ON_Object::UserDataConflictResolution userdata_conflict_resolution, bool bDeleteAllSourceItems)ON_Object
MoveUserData(ON_Object &source_object)ON_Object
New()ON_NurbsCurvestatic
New(const ON_NurbsCurve &nurbs_curve)ON_NurbsCurvestatic
New(const ON_BezierCurve &bezier_curve)ON_NurbsCurvestatic
New(int dimension, bool bIsRational, int order, int cv_count)ON_NurbsCurvestatic
NurbsCurve(ON_NurbsCurve *pNurbsCurve=nullptr, double tolerance=0.0, const ON_Interval *subdomain=nullptr) constON_Curve
ObjectType() const overrideON_Curvevirtual
ON_Curve() ON_NOEXCEPTON_Curve
ON_Curve(const ON_Curve &)ON_Curve
ON_Geometry()=defaultON_Geometry
ON_Geometry(const ON_Geometry &)=defaultON_Geometry
ON_NurbsCurve() ON_NOEXCEPTON_NurbsCurve
ON_NurbsCurve(const ON_NurbsCurve &)ON_NurbsCurve
ON_NurbsCurve(const ON_BezierCurve &bezier_curve)ON_NurbsCurve
ON_NurbsCurve(int dimension, bool bIsRational, int order, int cv_count)ON_NurbsCurve
ON_Object() ON_NOEXCEPTON_Object
ON_Object(const ON_Object &)ON_Object
operator=(const ON_NurbsCurve &src)ON_NurbsCurve
operator=(const ON_BezierCurve &bezier_curve)ON_NurbsCurve
ON_Curve::operator=(const ON_Curve &)ON_Curve
ON_Geometry::operator=(const ON_Geometry &)=defaultON_Geometry
ON_Object::operator=(const ON_Object &)ON_Object
Order(void) constON_NurbsCurve
ParameterSearch(double t, int &index, bool bEnableSnap, const ON_SimpleArray< double > &m_t, double RelTol=ON_SQRT_EPSILON) constON_Curveprotected
PointAt(double t) constON_Curve
PointAtEnd() constON_Curve
PointAtStart() constON_Curve
PurgeUserData()ON_Object
Read(ON_BinaryArchive &binary_archive) overrideON_NurbsCurvevirtual
RemoveKnots(int i0, int i1, double tolerance=0.0)ON_NurbsCurve
RemoveShortSegments(double tolerance, bool bRemoveShortSegments=true) overrideON_NurbsCurvevirtual
RemoveSingularSpans()ON_NurbsCurve
RemoveSpan(int span_index)ON_NurbsCurve
RepairBadKnots(double knot_tolerance=0.0, bool bRepair=true)ON_NurbsCurve
Reparameterize(double c)ON_NurbsCurve
ReserveCVCapacity(int)ON_NurbsCurve
ReserveKnotCapacity(int)ON_NurbsCurve
Reverse() overrideON_NurbsCurvevirtual
Rotate(double sin_angle, double cos_angle, const ON_3dVector &rotation_axis, const ON_3dPoint &rotation_center)ON_Geometry
Rotate(double rotation_angle, const ON_3dVector &rotation_axis, const ON_3dPoint &rotation_center)ON_Geometry
Scale(double scale_factor)ON_Geometry
SetComponentStates(ON_COMPONENT_INDEX component_index, ON_ComponentStatus states_to_set) constON_Objectvirtual
SetComponentStatus(ON_COMPONENT_INDEX component_index, ON_ComponentStatus status_to_copy) constON_Objectvirtual
SetCV(int, ON::point_style, const double *)ON_NurbsCurve
SetCV(int, const ON_3dPoint &)ON_NurbsCurve
SetCV(int, const ON_4dPoint &)ON_NurbsCurve
SetDomain(double t0, double t1) overrideON_NurbsCurvevirtual
ON_Curve::SetDomain(ON_Interval domain)ON_Curve
SetEndPoint(ON_3dPoint end_point) overrideON_NurbsCurvevirtual
SetKnot(int knot_index, double knot_value)ON_NurbsCurve
SetStartPoint(ON_3dPoint start_point) overrideON_NurbsCurvevirtual
SetSubDFriendlyTag(bool bSubDFriendlyTag)ON_NurbsCurve
SetUnclampedTagForExperts(bool bUnclampedTag)ON_NurbsCurve
SetUserString(const wchar_t *key, const wchar_t *string_value)ON_Object
SetUserStrings(int count, const ON_UserString *user_strings, bool bReplace)ON_Object
SetWeight(int, double)ON_NurbsCurve
SignedCurvatureAt(double t, const ON_3dVector *plane_normal=nullptr) constON_Curve
SizeOf() const overrideON_NurbsCurvevirtual
SpanCount() const overrideON_NurbsCurvevirtual
SpanIsLinear(int span_index, double min_length, double tolerance) constON_NurbsCurve
SpanIsLinear(int span_index, double min_length, double tolerance, ON_Line *line) constON_NurbsCurve
SpanIsSingular(int span_index) constON_NurbsCurve
Split(double split_param, ON_Curve *&left_result, ON_Curve *&right_result) const overrideON_NurbsCurvevirtual
SubDFriendlyTag() constON_NurbsCurve
SuperfluousKnot(int) constON_NurbsCurve
SwapCoordinates(int i, int j) overrideON_NurbsCurvevirtual
TangentAt(double t) constON_Curve
ThisIsNullptr(bool bSilentError) constON_Object
TightBoundingBox() constON_Geometry
Transform(const ON_Xform &xform) overrideON_NurbsCurvevirtual
TransformUserData(const class ON_Xform &xform)ON_Object
Translate(const ON_3dVector &translation_vector)ON_Geometry
Trim(const ON_Interval &) overrideON_NurbsCurvevirtual
TrimClosedCurve(const ON_Interval &in)ON_NurbsCurve
UnclampedTagForExperts() constON_NurbsCurve
UnclampEndForExperts(int end)ON_NurbsCurve
UnmanageKnotForExperts(int &knot_capacity, double *&knot)ON_NurbsCurve
UnsetON_Geometrystatic
UpdateReferencedComponents(const class ON_ComponentManifest &source_manifest, const class ON_ComponentManifest &destination_manifest, const class ON_ManifestMap &manifest_map)ON_Objectvirtual
UserDataConflictResolution enum nameON_Object
UserStringCount() constON_Object
Weight(int) constON_NurbsCurve
Write(ON_BinaryArchive &binary_archive) const overrideON_NurbsCurvevirtual
ZeroCVs()ON_NurbsCurve
~ON_Curve()ON_Curvevirtual
~ON_Geometry()=defaultON_Geometry
~ON_NurbsCurve()ON_NurbsCurvevirtual
~ON_Object()ON_Objectvirtual