Rhino C++ API  8.5
Public Member Functions | List of all members
RhRdk::Realtime::DisplayMode::IHUDCallbacks Class Referenceabstract

#include <RhRdk_RDP_DisplayPipeline.h>

Inheritance diagram for RhRdk::Realtime::DisplayMode::IHUDCallbacks:
RhRdk::Realtime::DisplayMode::IHUDFunctionality RhRdk::Realtime::DisplayMode::IHUDCallbacks3

Public Member Functions

virtual ~IHUDCallbacks ()
 
virtual bool AllowMaximumPassesEdit () const =0
 
virtual ON_wString CustomStatusText () const =0
 
virtual void * EVF (const wchar_t *, void *)=0
 
virtual int LastRenderedPass () const =0
 
virtual int MaximumPasses (void) const =0
 
virtual ON_wString ProductName () const =0
 
virtual bool RendererLocked (void) const =0
 
virtual bool RendererPaused (void) const =0
 
virtual time_t RenderStartTime (void) const =0
 
virtual void SetMaximumPasses (int) const =0
 
virtual bool Show (void) const =0
 
virtual bool ShowControls (void) const =0
 
virtual bool ShowCustomStatusText (void) const =0
 
virtual bool ShowMaximumPasses (void) const =0
 
virtual bool ShowPasses (void) const =0
 

Detailed Description

Support for built in HUD

Constructor & Destructor Documentation

◆ ~IHUDCallbacks()

virtual RhRdk::Realtime::DisplayMode::IHUDCallbacks::~IHUDCallbacks ( )
inlinevirtual

Member Function Documentation

◆ AllowMaximumPassesEdit()

virtual bool RhRdk::Realtime::DisplayMode::IHUDCallbacks::AllowMaximumPassesEdit ( ) const
pure virtual

Return true if you want to allow the user to edit the maximum passes count from the HUD.

◆ CustomStatusText()

virtual ON_wString RhRdk::Realtime::DisplayMode::IHUDCallbacks::CustomStatusText ( ) const
pure virtual

Return the custom status text to be shown if ShowCustomStatusText() returns true.

◆ EVF()

virtual void* RhRdk::Realtime::DisplayMode::IHUDCallbacks::EVF ( const wchar_t *  ,
void *   
)
pure virtual

◆ LastRenderedPass()

virtual int RhRdk::Realtime::DisplayMode::IHUDCallbacks::LastRenderedPass ( ) const
pure virtual

Return the pass that has been rendered at the time of calling this function.

◆ MaximumPasses()

virtual int RhRdk::Realtime::DisplayMode::IHUDCallbacks::MaximumPasses ( void  ) const
pure virtual

Return the requested maximum passes.

◆ ProductName()

virtual ON_wString RhRdk::Realtime::DisplayMode::IHUDCallbacks::ProductName ( ) const
pure virtual

Return the name of the renderer

◆ RendererLocked()

virtual bool RhRdk::Realtime::DisplayMode::IHUDCallbacks::RendererLocked ( void  ) const
pure virtual

Return true if the renderer is locked.

◆ RendererPaused()

virtual bool RhRdk::Realtime::DisplayMode::IHUDCallbacks::RendererPaused ( void  ) const
pure virtual

Return true if the renderer is paused.

◆ RenderStartTime()

virtual time_t RhRdk::Realtime::DisplayMode::IHUDCallbacks::RenderStartTime ( void  ) const
pure virtual

Return the start time of the rendering.

◆ SetMaximumPasses()

virtual void RhRdk::Realtime::DisplayMode::IHUDCallbacks::SetMaximumPasses ( int  ) const
pure virtual

The user has changed the amount of maximum passes through the HUD.

◆ Show()

virtual bool RhRdk::Realtime::DisplayMode::IHUDCallbacks::Show ( void  ) const
pure virtual

Return true if you want the HUD to show.

◆ ShowControls()

virtual bool RhRdk::Realtime::DisplayMode::IHUDCallbacks::ShowControls ( void  ) const
pure virtual

Return true if you want to show HUD controls.

◆ ShowCustomStatusText()

virtual bool RhRdk::Realtime::DisplayMode::IHUDCallbacks::ShowCustomStatusText ( void  ) const
pure virtual

Return true if you want to show custom status text in the HUD.

◆ ShowMaximumPasses()

virtual bool RhRdk::Realtime::DisplayMode::IHUDCallbacks::ShowMaximumPasses ( void  ) const
pure virtual

Return true if you want to show the maximum pass count in the HUD.

◆ ShowPasses()

virtual bool RhRdk::Realtime::DisplayMode::IHUDCallbacks::ShowPasses ( void  ) const
pure virtual

Return true if you want to show the current pass count in the HUD.