Rhino C++ API  8.6
Public Attributes | List of all members
ON_WindowsBITMAPFILEHEADER Struct Reference

Windows packs BITMAPFILEHEADER. More...

#include <opennurbs_bitmap.h>

Public Attributes

unsigned int bfOffBits
 DWORD = offset, in bytes, from the beginning of the BITMAPFILEHEADER structure to the bitmap bits. More...
 
unsigned short bfReserved1
 WORD Reserved; must be zero. More...
 
unsigned short bfReserved2
 WORD Reserved; must be zero. More...
 
unsigned int bfSize
 DWORD = size, in bytes, of the bitmap file. More...
 
unsigned short bfType
 WORD = file type, must be BM. More...
 

Detailed Description

Windows packs BITMAPFILEHEADER.

Member Data Documentation

◆ bfOffBits

unsigned int ON_WindowsBITMAPFILEHEADER::bfOffBits

DWORD = offset, in bytes, from the beginning of the BITMAPFILEHEADER structure to the bitmap bits.

◆ bfReserved1

unsigned short ON_WindowsBITMAPFILEHEADER::bfReserved1

WORD Reserved; must be zero.

◆ bfReserved2

unsigned short ON_WindowsBITMAPFILEHEADER::bfReserved2

WORD Reserved; must be zero.

◆ bfSize

unsigned int ON_WindowsBITMAPFILEHEADER::bfSize

DWORD = size, in bytes, of the bitmap file.

◆ bfType

unsigned short ON_WindowsBITMAPFILEHEADER::bfType

WORD = file type, must be BM.