Rhino C++ API  8.6
Public Attributes | List of all members
ON_WindowsBITMAPINFO Struct Reference

#include <opennurbs_bitmap.h>

Public Attributes

ON_WindowsRGBQUAD bmiColors [1]
 
ON_WindowsBITMAPINFOHEADER bmiHeader
 

Member Data Documentation

◆ bmiColors

ON_WindowsRGBQUAD ON_WindowsBITMAPINFO::bmiColors[1]

The "[1]" is for the compiler. In practice this array commonly has length 0, 3, or 256 and a BITMAPINFO* points to a contiguous piece of memory that contains

     BITMAPINFOHEADER
     RGBQUAD[length determined by flags]
     unsigned char[biSizeImage]

See the ON_WindowsBITMAPINFOHEADER comments and http://msdn.microsoft.com/default.asp for more details.

◆ bmiHeader

ON_WindowsBITMAPINFOHEADER ON_WindowsBITMAPINFO::bmiHeader

Mimics Windows BITMAPINFO structure. For details searh for "BITMAPINFO" at http://msdn.microsoft.com/default.asp