Click or drag to resize

GH_Item Constructor (String, Int32, GH_Line)

Construct a new instance of GH_Item with the specified name, index and value.

Namespace:  GH_IO.Types
Assembly:  GH_IO (in GH_IO.dll)
Syntax
public GH_Item(
	string item_name,
	int item_index,
	GH_Line item_data
)

Parameters

item_name
Type: SystemString
Name of new item.
item_index
Type: SystemInt32
Index of new item. Any index less than zero will be clamped to -1.
item_data
Type: GH_IO.TypesGH_Line
Value of new item.
Exceptions
ExceptionCondition
ArgumentNullExceptionThrown if the specified name string is null or empty.
See Also