Click or drag to resize

GH_ResizeBorderSetup Method (RectangleF, PointF, PointF, SizeF, SizeF)

Set up a new sizing operation.

Namespace:  Grasshopper.GUI.Canvas
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public void Setup(
	RectangleF ShapeRegion,
	PointF ShapePivot,
	PointF MouseCursor,
	SizeF MinSize,
	SizeF MaxSize
)

Parameters

ShapeRegion
Type: System.DrawingRectangleF
Shape of the object to resize.
ShapePivot
Type: System.DrawingPointF
Pivot of the object to resize.
MouseCursor
Type: System.DrawingPointF
Location of cursor in shape space coordinates.
MinSize
Type: System.DrawingSizeF
Minimum allowed size for shape.
MaxSize
Type: System.DrawingSizeF
Maximum allowed size for shape.
See Also