Click or drag to resize

GH_TreeFilterFindPathBrackets Method

Locate the two curly brackets that delineate the path segment of an Index Rule set.

Namespace:  Grasshopper.Kernel.Data
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public static bool FindPathBrackets(
	string text,
	out int index0,
	out int index1
)

Parameters

text
Type: SystemString
String to search.
index0
Type: SystemInt32
Index of opening curly bracket.
index1
Type: SystemInt32
Index of closing curly bracket.

Return Value

Type: Boolean
True if valid brackets were found, false if not.
See Also