Click or drag to resize

GH_TreeFilterFindPrevLevelChar Method

Find the previous occurance of a char in a string that is level with the search start index.

Namespace:  Grasshopper.Kernel.Data
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public static int FindPrevLevelChar(
	string text,
	int index,
	char char
)

Parameters

text
Type: SystemString
String to search.
index
Type: SystemInt32
Index to search from.
char
Type: SystemChar
Char to match.

Return Value

Type: Int32
The index of the first level character match or -1 if no such character could be found.
See Also