Click or drag to resize

GH_ExpressionSyntaxWriterRewriteForEvaluator Method (String)

Rewrite the expression so that all temporary keywords and symbols are replaced by evaluator-specific chars. The expression will become less readable, do not let the user see the result of this function. You need to rewrite the expression with this function if you intend to feed it into the Evaluator.

Namespace:  Grasshopper.Kernel.Expressions
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public static string RewriteForEvaluator(
	string Expression
)

Parameters

Expression
Type: SystemString

Return Value

Type: String
See Also